5 releases

0.11.0-beta.5 Mar 29, 2024
0.11.0-beta.4 Dec 30, 2023
0.11.0-beta.3 Dec 25, 2023
0.11.0-alpha.2 Nov 19, 2023
0.11.0-alpha.1 Nov 14, 2023

#19 in #lnp-bp

Download history 241/week @ 2023-12-25 91/week @ 2024-01-01 8/week @ 2024-01-08 5/week @ 2024-02-19 19/week @ 2024-02-26 64/week @ 2024-03-04 27/week @ 2024-03-11 4/week @ 2024-03-18 242/week @ 2024-03-25 103/week @ 2024-04-01

389 downloads per month

Apache-2.0

64KB
1.5K SLoC

RGB wallet & standard libraries for smart contracts on Bitcoin & Lightning

Build Tests Lints codecov

crates.io Docs unsafe forbidden Apache-2 licensed

RGB is confidential & scalable client-validated smart contracts for Bitcoin & Lightning. To learn more about RGB please check RGB blueprint and RGB FAQ websites.

RGB wallet standard library provides non-consensus-critical high-level API for RGB applications. It is based on [RGB Core Lib][Core], implementing validation and consensus rules for RGB smart contracts.

The development of the project is supported and managed by LNP/BP Standards Association. The design of RGB smart contract system and implementation of this and underlying consensus libraries was done in 2019-2022 by Dr Maxim Orlovsky basing or earlier ideas of client-side-validation and RGB as "assets for bitcoin and LN" by Peter Todd and Giacomo Zucco. Upon the release of RGBv1 the protocol will be immutable and this library will accept only bugfixes; i.e. it will be ossified by requiring consensus ACK for the new changes across the large set of maintainers.

The current list of the projects based on the library include:

  • RGB Node: standalone & embeddable node for running RGB.
  • [MyCitadel Node][MyCitadel Node]: wallet node providing RGB smart contract functionality integrated with Lightning network, bitcoin blockchain indexers, decentralized data storage and propagation (Storm) and wallet services. It can run as embedded, desktop, server or cloud-based node.

Library

The library can be integrated into other rust projects via Cargo.toml [dependencies] section:

rgb-wallet = "0.10.0"

If the library will be used for wallet applications and work with PSBT files, than use wallet feature, which is non-default:

[dependencies]
rgb-wallet = { version = "0.8", features = ["wallet"] }

For serialization purposes library provides serde feature, which is turned off by default.

MSRV

Minimum supported rust compiler version (MSRV): 1.66, rust 2021 edition.

Contributing

Altcoins and "blockchains" other than Bitcoin blockchain/Bitcoin protocols are not supported and not planned to be supported; pull requests targeting them will be declined.

License

See LICENCE file.

Dependencies

~20MB
~291K SLoC