libp2prs-tcp is used at run time in 2 crates. It's used only as a dev dependency in 5 crates.

Depender (with downloads and own rev deps) libp2prs-tcp version
libp2p-rs optional ^0.3.0
2 libp2prs-dns dev ^0.3.0
1 libp2prs-floodsub dev ^0.3.0
1 libp2prs-kad dev ^0.3.0
1 libp2prs-noise dev ^0.3.0
1 libp2prs-websocket ^0.3.0
3 libp2prs-yamux dev ^0.3.0