3 releases (breaking)

0.3.0 Jul 28, 2023
0.2.0 Feb 10, 2023
0.1.0 Feb 10, 2023

#16 in #poly-mesh

33 downloads per month

Apache-2.0

12KB
174 lines

Upgrade tracker contract for easier upgrading of APIs.

Build

Install cargo-contract.

cargo install cargo-contract --force

Build the contract: cargo +nightly contract build --release

Contract file needed for deployment ./target/ink/polymesh_ink_upgrade_tracker.contract.

Setup.

Deploy the contract polymesh_ink_upgrade_tracker.contract. The account used will be the admin.

Use

Call the upgrade_wrapped_api(<api version>, Upgrade { chain_version: ChainVersion { spec: 5_002_001, tx: 3}, hash: <code hash of upgraded api>}) to upgrade an API.


lib.rs:

This contract is for managing upgradable APIs.

Dependencies

~14–26MB
~376K SLoC