#http #hyper #hyperium #authentication

www-authenticate

missing HTTP WWW-Authenticate header parser/printer for hyper 0.11.x. 0.1.x for hyper 0.10.y, 0.2.x for hyper 0.11.y and 0.3.x for hyperx

4 releases (breaking)

Uses new Rust 2021

0.4.0 Dec 22, 2021
0.3.0 Jun 19, 2018
0.2.0 Jun 9, 2018
0.1.0 Jul 19, 2017

#124 in HTTP server

Download history 2451/week @ 2021-09-26 2332/week @ 2021-10-03 2235/week @ 2021-10-10 2388/week @ 2021-10-17 2089/week @ 2021-10-24 1360/week @ 2021-10-31 2246/week @ 2021-11-07 2229/week @ 2021-11-14 1560/week @ 2021-11-21 1852/week @ 2021-11-28 2312/week @ 2021-12-05 2170/week @ 2021-12-12 776/week @ 2021-12-19 617/week @ 2021-12-26 2459/week @ 2022-01-02 2055/week @ 2022-01-09

5,971 downloads per month
Used in 8 crates (2 directly)

MIT license

41KB
962 lines

www-authenticate

Travis Build Status MIT licensed crates.io

missing HTTP WWW-Authenticate header parser/printer for hyper/hyperx. 0.1.x for hyper 0.10.y and 0.2.x, hyper 0.11.y and 0.3.x for hyperx, 0.4.x for hyperx 0.13.0

Documentation

released


lib.rs:

www-authenticate missing HTTP WWW-Authenticate header parser/printer for hyper

Dependencies

~3.5MB
~89K SLoC

a