#version #rustc #check #minimum

build version_check

Tiny crate to check the version of the installed/running rustc

8 releases

0.9.1 May 24, 2019
0.9.0 May 24, 2019
0.1.5 Sep 23, 2018
0.1.4 Jul 5, 2018
0.1.0 Jan 15, 2017

#203 in Development tools

Download history 79313/week @ 2019-08-02 84109/week @ 2019-08-09 82605/week @ 2019-08-16 83985/week @ 2019-08-23 84241/week @ 2019-08-30 92293/week @ 2019-09-06 90513/week @ 2019-09-13 90124/week @ 2019-09-20 94395/week @ 2019-09-27 103038/week @ 2019-10-04 98873/week @ 2019-10-11 101846/week @ 2019-10-18 103369/week @ 2019-10-25 105639/week @ 2019-11-01 122609/week @ 2019-11-08

286,657 downloads per month
Used in 5,068 crates (37 directly)

MIT/Apache

32KB
380 lines

version_check

Build Status Current Crates.io Version rustdocs on docs.rs

This tiny crate checks that the running or installed rustc meets some version requirements. The version is queried by calling the Rust compiler with --version. The path to the compiler is determined first via the RUSTC environment variable. If it is not set, then rustc is used. If that fails, no determination is made, and calls return None.

Usage

Add to your Cargo.toml file, typically as a build dependency:

[build-dependencies]
version_check = "0.9"

version_check is compatible and compiles with Rust 1.0.0 and beyond.

Examples

Set a cfg flag in build.rs if the running compiler was determined to be at least version 1.13.0:

extern crate version_check as rustc;

if rustc::is_min_version("1.13.0").unwrap_or(false) {
    println!("cargo:rustc-cfg=question_mark_operator");
}

Check that the running compiler was released on or after 2018-12-18:

extern crate version_check as rustc;

match rustc::is_min_date("2018-12-18") {
    Some(true) => "Yep! It's recent!",
    Some(false) => "No, it's older.",
    None => "Couldn't determine the rustc version."
};

Check that the running compiler supports feature flags:

extern crate version_check as rustc;

match rustc::is_feature_flaggable() {
    Some(true) => "Yes! It's a dev or nightly release!",
    Some(false) => "No, it's stable or beta.",
    None => "Couldn't determine the rustc version."
};

See the rustdocs for more examples and complete documentation.

Alternatives

This crate is dead simple with no dependencies. If you need something more and don't care about panicking if the version cannot be obtained, or if you don't mind adding dependencies, see rustc_version.

License

version_check is licensed under either of the following, at your option:

No runtime deps