VersionReleased Dependency changes Downloads/mo MSRV
0.9.3 Mar 21, 2021
  • thiserror
  • crossbeam 0.8.1
  • env_logger 0.8.4
  • rusqlite 0.24.2
  • weave 0.3.0
  • failure
  • failure_derive
7 1.45
0.9.0 Sep 8, 2019
  • crossbeam
  • data-encoding
  • lazy_static
  • num_cpus
  • rusqlite
  • tempdir
  • env_logger 0.6.2
  • structopt 0.3.23
  • rustc-serialize
  • structopt-derive
1.37~1.36
0.8.1 May 19, 2018
  • regex 1.5.4
  • clap
1.26~1.20
0.8.0 Mar 7, 2018
  • chrono
  • failure
  • failure_derive
  • structopt
  • structopt-derive
  • env_logger 0.5.13
  • flate2 1.0.22
  • log 0.4.14
  • openssl 0.10.36
  • weave 0.2.2
  • error-chain
1.24~1.20
0.7.0 Aug 6, 2017
  • weave
  • error-chain 0.10.0
  • openssl 0.9.24
  • regex 0.2.11
1.19~1.17
0.6.2 Nov 11, 2016 47 1.13~1.3
0.6.1 Oct 28, 2016
  • error-chain 0.5.0
1.12~1.3
0.6.0 Aug 2, 2016 1.10~1.3
0.5.0 Jul 31, 2016
  • error-chain 0.2.2
1.10~1.3
0.4.0 Jul 21, 2016 1.10~1.3

Minimum Supported Rust Version (MSRV) is only approximate. A range of two versions means "oldest rustc verified to work ~ oldest rustc that might work". Actual MSRV will vary depending on crate features, target platform, and dependency versions. The data is estimated based on the latest stable Rust version available at the time the crate has been published and cargo check on Linux/x86-64.