#gtk #winapi #gdk4 #api-bindings #gnome

gdk4-win32

Rust bindings of the GDK4 Win32 library

13 unstable releases (4 breaking)

0.8.2 Apr 26, 2024
0.8.1 Mar 7, 2024
0.8.0 Feb 4, 2024
0.7.2 Aug 12, 2023
0.5.2 Nov 17, 2022

#644 in GUI

Download history 168/week @ 2024-02-25 349/week @ 2024-03-03 157/week @ 2024-03-10 202/week @ 2024-03-17 81/week @ 2024-03-24 179/week @ 2024-03-31 199/week @ 2024-04-07 105/week @ 2024-04-14 273/week @ 2024-04-21 189/week @ 2024-04-28 174/week @ 2024-05-05 95/week @ 2024-05-12 113/week @ 2024-05-19 90/week @ 2024-05-26 139/week @ 2024-06-02 121/week @ 2024-06-09

469 downloads per month
Used in 6 crates (via gst-plugin-gtk4)

MIT license

790KB
19K SLoC

Rust GDK 4 Win32 bindings

The project website is here.

Rust bindings of GDK 4's Win32 backend, part of gtk4-rs.

GDK is an intermediate layer that isolates GTK from the details of the windowing system. GDK Win32 contains functions specific to the Win32 backend.

Minimum supported Rust version

Currently, the minimum supported Rust version is 1.70.

Documentation

Using

We recommend using crates from crates.io, as demonstrated here.

If you want to track the bleeding edge, use the git dependency instead:

[dependencies]
gdk-win32= { git = "https://github.com/gtk-rs/gtk4-rs.git", package = "gdk4-win32" }

Avoid mixing versioned and git crates like this:

# This will not compile
[dependencies]
gdk-x11 = {version = "0.1", package = "gdk4-x11"}
gdk-win32 = { git = "https://github.com/gtk-rs/gtk4-rs.git", package = "gdk4-win32" }

Features

Feature Description
v4_4 Enable the new APIs part of GTK 4.4
egl Integration with the khronos-egl crate
win32 Integration with the windows crate

See Also

License

The Rust bindings of gdk4-win32 are available under the MIT License, please refer to it.

Dependencies

~8–47MB
~745K SLoC