18 releases

✓ Uses Rust 2018 edition

0.3.0-alpha.16 May 10, 2019
0.3.0-alpha.13 Feb 21, 2019
0.3.0-alpha.11 Dec 27, 2018
0.3.0-alpha.10 Nov 27, 2018
0.3.0-alpha.2 Jul 30, 2018
Download history 3940/week @ 2019-01-25 4390/week @ 2019-02-01 5698/week @ 2019-02-08 4401/week @ 2019-02-15 3904/week @ 2019-02-22 4402/week @ 2019-03-01 3593/week @ 2019-03-08 3529/week @ 2019-03-15 2598/week @ 2019-03-22 2071/week @ 2019-03-29 1855/week @ 2019-04-05 1835/week @ 2019-04-12 1419/week @ 2019-04-19 1971/week @ 2019-04-26 1788/week @ 2019-05-03

10,113 downloads per month
Used in 145 crates (26 directly)

MIT/Apache

40KB
590 lines

futures-rs

Zero-cost asynchronous programming in Rust

Build Status Crates.io

Documentation | Website

Usage

Add this to your Cargo.toml:

[dependencies]
futures-preview = "0.3.0-alpha.14"

Now, you can use futures-rs:

use futures::future::Future; // Note: It's not `futures_preview`

The current version of futures-rs requires Rust nightly 2019-04-15 or later.

Feature std

Futures-rs works without the standard library, such as in bare metal environments. However, it has a significantly reduced API surface. To use futures-rs in a #[no_std] environment, use:

[dependencies]
futures-preview = { version = "=0.3.0-alpha.14", default-features = false }

License

This project is licensed under either of

at your option.

Contribution

Unless you explicitly state otherwise, any contribution intentionally submitted for inclusion in futures-rs by you, as defined in the Apache-2.0 license, shall be dual licensed as above, without any additional terms or conditions.

No runtime deps