7 releases (breaking)

0.16.0 Oct 19, 2022
0.15.1 Jan 15, 2022
0.14.0 Jun 22, 2021
0.9.0 Jul 4, 2020
0.6.0 Feb 21, 2019

#11 in Accessibility

Download history 9528/week @ 2022-10-09 9156/week @ 2022-10-16 9843/week @ 2022-10-23 9729/week @ 2022-10-30 11761/week @ 2022-11-06 10755/week @ 2022-11-13 10505/week @ 2022-11-20 10459/week @ 2022-11-27 13169/week @ 2022-12-04 14709/week @ 2022-12-11 13086/week @ 2022-12-18 10717/week @ 2022-12-25 12225/week @ 2023-01-01 15439/week @ 2023-01-08 12217/week @ 2023-01-15 12362/week @ 2023-01-22

53,389 downloads per month
Used in 3 crates

MIT license

375KB
9K SLoC

Rust ATK bindings

Project site is here.

Rust bindings and wrappers for ATK, part of gtk3-rs.

ATK 2.28 is the lowest supported version for the underlying library.

Minimum supported Rust version

Currently, the minimum supported Rust version is 1.63.0.

Documentation

Using

We recommend using crates from crates.io, as demonstrated here.

If you want to track the bleeding edge, use the git dependency instead:

[dependencies]
atk = { git = "https://github.com/gtk-rs/gtk3-rs.git", package = "atk" }

Avoid mixing versioned and git crates like this:

# This will not compile
[dependencies]
atk = "0.13"
atk = { git = "https://github.com/gtk-rs/gtk3-rs.git", package = "atk" }

See Also

License

atk is available under the MIT License, please refer to it.

Dependencies

~5.5MB
~118K SLoC